
Common borders. Common solutions.Common borders. Common solutions.

Module 2: The application of EO for Coastal line changes with the example 

of assessments via PONTOS platform

VIRTUAL TRAINING MODULES 

2022

PONTOS-EU.AUA.AM



Common borders. Common solutions.Common borders. Common solutions.

Module 2 

The application of EO for Coastal line changes 

with the example of assessments via PONTOS 

platform



Common borders. Common solutions.Common borders. Common solutions.

Responsible Partner Democritus University of Thrace

Supporting Partner – Environmental Protection and Monitoring Inspection Body of RA

Slides and scripts prepared by – Zachopoulos Konstantinos, Kokkos Nikolaos, Prof. Sylaios Georgios

Contact Information – gsylaios@env.duth.gr 

This module is developed in the frames of the BSB 889 PONTOS Project



Common borders. Common solutions.Common borders. Common solutions.

LEARNING OBJECTIVES OF MODULE 2

Familiarize with the open source satellite image platforms 

Download historical satellite images

Process of shoreline extraction from satellite images

Evaluation of shoreline movements through the years
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MODULE STRUCTURE

Introduction in Coastal Erosion and Remote Sensing

Description of the Methodology Workflow

Results Visualization
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Spatial Resolution
The spatial resolution specifies the pixel size of satellite images covering the 
Earth surface.

Temporal Resolution
The temporal resolution specifies the revisiting frequency of a satellite sensor for
a specific location.

Spectral Resolution
The number of spectral bands in which the sensor can collect reflected radiance.
But also the position of bands in the electromagnetic spectrum.

Introduction to satellite sensors characteristics
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Percentage of the image covered by cloudsCloud percentage

The distance in meters between pixel centers measured on the 
ground

Ground sample 
distance

Pixel resolution of the image in metersPixel Resolution

Spacecraft across-track off-nadir viewing angle used for imaging, 
in degrees (“+” being East and “-” being West)

Off-nadir angle

Elevation angle of the sun in degrees (0-90)Sun elevation

Angle from the true North to the sun vector projected on the 
horizontal plane in degrees (0-360)Sun azimuth

Introduction to satellite sensors characteristics
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Methodology applied in a coastal 
erosion assessment 
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NDWI
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Open source databases for 
satellite images
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https://earthexplorer.usgs.gov/ https://scihub.copernicus.eu/dhus

https://www.planet.com/explorer/

Open source databases for satellite images

https://earthexplorer.usgs.gov/
https://scihub.copernicus.eu/dhus/
https://www.planet.com/explorer/
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https://sentinel.esa.int/web/sentinel/sentinel-data-access

Open source databases for satellite images

https://sentinel.esa.int/web/sentinel/sentinel-data-access
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Landsat 5 ETM
•Spatial Res.: 30m
•1984 – 2013
•Number of Bands: 7

Sentinel 2A & 2B
•Spatial Res.: 10, 20, 
60m

•2015 – Still active
•Number of Bands: 13
•Number of Sat.: 2

RapidEye
•Spatial Res.: 5 m
•2009 – March 2020
•Number of Bands: 5
•Number of Sat.: 5

PlanetScope
•Spatial Res.: 3.6 m
•2016 – Still active
•Number of Bands: 4
•Number of Sat.: more 
than 120 optical 
satellites

Landsat 8
• Spatial Res.: 30m
• 2013 – Still active
• Number of Bands: 8

Earth Explorer Copernicus Hub Planet Explorer Planet Explorer

Open source products
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Earth Observation Tools
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Earth Observation Tools

Plug-ins

https://qgis.org/en/site/forusers/download.html

GIS Software

https://pro.arcgis.com/en/pro-app/get-
started/install-and-sign-in-to-arcgis-pro.htm

https://plugins.qgis.org/plugins/SemiAutom
aticClassificationPlugin/

https://www.usgs.gov/centers/whcmsc/science/d
igital-shoreline-analysis-system-dsas?qt-

science_center_objects=0#qt-
science_center_objects

https://qgis.org/en/site/forusers/download.html
https://pro.arcgis.com/en/pro-app/get-started/install-and-sign-in-to-arcgis-pro.htm
https://plugins.qgis.org/plugins/SemiAutomaticClassificationPlugin/
https://www.usgs.gov/centers/whcmsc/science/digital-shoreline-analysis-system-dsas?qt-science_center_objects=0#qt-science_center_objects
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Install QGIS

https://qgis.org/en/site/forusers/download.html

https://qgis.org/en/site/forusers/download.html
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Install Semi Automatic Classification plugin in QGIS

1. 2.

3.



Common borders. Common solutions.

Install QuickMapServices plugin in QGIS

- Plugins → Manage and Install Plugins… → search QuickMapServices → install
- Web → QuickMapServices → Settings → More Services → Get Contributed pack → Save
- Web → QuickMapServices → select your basemap
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Practical Session 1 
Earth Explorer and Copernicus Open 

Access Hub
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Earth Explorer
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Image selection should be based on:
• Clarity from cloud cover
• The correct geo-reference & Orthorectification
• The seasonality (e.g. all images retrieved in the summer months)
• Sea surface height (CMEMS data) / Tidal phase

Satellite image selection criteria
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Step 1: Create an account and login the Earth Explorer or sign in 

Login
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Step 2: Define the Area of Interest

- Use the interactive map and zoom to you area of Interest
- In the “Enter Search Criteria” tab select “use map” and the area enclosed to the screen is selected 
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Step 3: Define the “Date Range” for satellite images search

Define the Date Range Search images only for summer months
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Step 4: Select your Data Sets

In the “Data Sets” tab 
- Select your data set Landsat or Sentinel
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Step 5: Additional criteria

1. Data Set

2. Land Cloud Cover

3. Cloud Cover in the image

4. Spacecraft Identifier

5. Day / Night Indicator
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Step 6: image selection

In the tab “Results”

- Select the Data Set and a list of images is shown

- Download images with no cloud cover
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Step 8: Download image
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Copernicus Open Access Hub



Common borders. Common solutions.
Step 1: Open Copernicus Open Access Hub
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Step 2: Create an account and Login or sign in
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Step 4: Zoom in you Region of Interest
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Step 3: Create a polygon to define your ROI 
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Step 4: Define the date range for satellite image selection



Common borders. Common solutions.
Step 5: Select the Mission Sentinel 2 and search for results
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Step 6a: Select and download the satellite image
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Step 6b: Preview and download the satellite image
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Step 9: Open Sentinel 2 Downloaded file
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Practical Session 2
Shoreline Extraction
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Shoreline extraction methodology - Step by Step
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Step 1: Import the Green and NIR Band images

I. Decompress the  downloaded file
II. Find the GREEN and NIR band images
III. Import band images in the QGIS (Drag & Drop or Copy & Paste).

Landsat 4-5 = Green B2 & NIR B4
Landsat 8 = Green B3 & NIR B5
Sentinel 2 = Green B3 & NIR B8
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From the top bar select Raster → Raster Calculator, and the raster calculator window opens
• In the “output layer” field select the file to save the new layer (2021_NDWI.tif)

• In the field “Raster calculator expressions”, import the NDWI equation using the bands from the 
“raster bands” field

• Import  the brackets and the equation symbols from the “Operations” field

• Then press OK
• The new NDWI image (2021_NDWI.tif) is created and uploaded in the layer panel   

Step 2: NDWI calculation using raster calculator

( )

( )

GREEN NIR
NDWI

GREEN NIR

−
=

+
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From the top bar select Raster → Extraction → Clip Raster by Extent…, and the Clip Raster by Extent 
window opens
• In the “input layer” field select the NDWI image 
• In the “Clipping extent” field, select the button on the right and select the “Draw on canvas”

• Select the area of interest on the QGIS map by drawing a rectangular
• In the field “Clipped (extent)” define the name of the new image (2021_NDWI_clip.tif) and save it to the 

working directory file
• Press RUN and a new raster file will be generated
• A new Clipped file is created

Step 3: Clip NDWI image 
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Open the Semi-Automatic Classification Plug-in window from the button (1), and select the tab “Band set”
• In the field “band list” press the button refresh, select the NDWI clipped file (2021_NDWI_clip.tif) and then 

press the + button to import the file in the band set definition field and in the tab “Band set 1”

• Press RUN and the working file is set

Step 4: SCP Working file definition and training file creation

(1)
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Create a training file to save the ROIs 
• Select the Training input tab from the SCP Dock. Select the 

button “Create SCP training input”, name as train.scp and 
save in the working directory file

Train the Algorithm for Sea cover
• In the ROI & Signature list and in the field MC Name set 

Water, in the field C Name set Sea
• From the SCP toolbar select the “Activate ROI pointer”
• Select Sea pixels on the 2021_NDWI_clip layer
• Press the “Save Temporary ROI” Button to import the Sea ROI 

into the ROIs list
• Import more than 10 Sea ROIs into the ROI Signature list with 

the same procedure

Step 5: Create Regions of Interest (ROI)
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Step 5: Create Regions of Interest (ROI)

Train the Algorithm for Coast cover
• In the ROI & Signature list and in the field MC Name set Land, in the field C

Name set Coast
• Change the MC ID to 2
• From the SCP toolbar select the “Activate ROI pointer” or “Create a ROI 

polygon”
• Select Land pixels on the 2021_NDWI_clip layer
• Press the button “Save Temporary ROI” Button to import the Land ROI into 

the ROIs list
• Import more than 10 Land ROIs into the ROI Signature list with the same 

procedure
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Step 6: Satellite image Classification Preview

Classification Preview
• Select the button “Activate Classification preview Pointer” to activate the classification preview 
• Select the (T) to set the Preview transparency and (S) to Set the Preview size (in pixel unit)
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Step 7: Satellite image Classification

Open the Semi Automatic Classification Plug-in window and select from the Band Processing the tab Classification
• in the field Classification Check the box MC ID
• In the Algorithm field select the Minimum distance classification method
• Press RUN and save the classified raster file (2021_NDWI_Clip_class.tif) in the working directory
• A new classified raster file is created
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Step 8: Convert the Classified Raster file to Vector

Search on Processing Toolbox the Polygonize (Raster to Vector) tool
• In the field Input layer select the classified raster file
• In the field Vectorized define the name of the new file and the folder to save (2021_polygon.shp)
• Select Run and a new vector file will be generated
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Search on Processing Toolbox the Convert Polygons to Lines tool
• In the field Polygons select the Polygon file (2021_Polygon)
• In the field Lines define the name of the new file and the folder to save (2021_Shoreline.shp)
• Select Run and a new vector file will be generated

Step 9: Convert the Polygons to Lines
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Step 10: Edit and smooth shoreline

• Select the shoreline file (2021_shoreline.shp)
• Select Toggle editing tool and edit the shoreline using the tools:

o Split Parts
o Split Features
o Vertex Tool etc

• Delete the outer lines and keep only the main shoreline
• For stop editing press Toggle editing tool 

Smooth Shoreline
Select Smooth tool from the Processing Toolbox
• Input layer → 2021_shoreline
• Offset → 0.5
• Smoothed → save as 2021_shoreline_smooth.shp
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• Apply the same steps for every historical satellite images to extract the historical shorelines

Step 11: Extract every historical shoreline

List of generated files Historical shorelines
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Practical Session 3
Evaluation of the Shoreline 

Evolution
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Introduction in DSAS tool
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Introduction in DSAS tool
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Net Shoreline MovementNSM

Shoreline Change EnvelopeSCE

End Point RateEPR

Linear Regression RateLRR

Standard Error of Linear RegressionLSE

Confidence Interval of Linear RegressionLCI

R-squared of Linear RegressionLR2

Weighted Linear Regression RateWLR

Standard Error of Weighted Linear RegressionWSE

Confidence of Weighted Linear RegressionWCI

R-squared of Linear RegressionWR2

Least Median of SquaresLMS

Introduction in DSAS Statistics
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Net Shoreline Movement (NSM)

End Point Rate (EPR)

Weighted Linear Regression (WLR)

Shoreline Change Envelope (SCE)
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Step 1st: Create a Personal Geodatadase (.mdb) and new Feature Classes

Step 2nd: Import the historical shorelines In ArcMap

Step 3rd: Pre-process of the shorelines and Edit the Shorelines Feature class

Step 4th: Pre-process of the baseline and import in baseline Feature Class

Step 5th: Define the technical characteristics of the vertical Transects in DSAS toolbox

Step 6th: Edit Transects

Step 7th: Calculate the Statistical Parameters

Step 8th: Visualization of the results

Step 9th: Open the Attribute tables from the generated files

Step 10th: Export the parameters in .txt file

Step 11th: Indicative Results – East Nestos Estuaries

Methodology in steps - ArcMap & DSAS
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Create a new Personal Geodatabase

• Catalog → New Personal Geodatabase 

• Rename → PONTOS_ PGB.mdb

Create 2 Feature Classes (shoreline & baseline)

• PONTOS_PGB.mdb (Right click) → New → Feature class…

Step 1: Create a new Personal Geodatabase and two Feature Classes

• Open ArcMap 10.9
• Define the Working directory saving the file in the 

DSAS_Transects folder: 
File → Save as → File name: DSAS_Transects.mxd
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• In the Tab Catalog → PONTOS_PGB.mdb (right click) → New → Feature class…

• In the field Name type shorelines

• Select Line Features in the field “Type of features stored…”, press next

• Select the coordinate system of your study site, and press next

• Fill the table with the Field name and the Data Type as given in the figure
• In the field DATES_ in the “Field Properties” in Length type 10

Step 1a: Create a new shoreline Feature Classes
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• In the Tab Catalog → PONTOS_PGB.mdb (right click) → New → Feature class…

• In the field Name type baseline

• Select Line Features in the field “Type of features stored…”, press next

• Select the coordinate system of your study site, and press next

• Fill the table with the Field name and the Data Type as given in the figure

Step 1b: Create a new baseline Feature Classes
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Step 2: Import the historical shorelines In ArcMap

i. Create a new Folder (e.g. DSAS_Transects)

ii. Copy the shoreline shapefiles to the DSAS_Transects folder

iii. Right click on the layers panel

iv. Add Data…

v. Select all the shoreline files

vi. Select Add

vii. The shorelines are imported in the ArcMap
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Create new field in the attribute table of the historical shoreline files

• Right click on the Shoreline Layer

• Open attribute table → Table options → Add Field

• Name: YEAR

• Type: Short Integer

• → OK

• Editor → Start Editing

• In the field YEAR define the shoreline date e.g. 2018

• → Stop Editing

• Apply the same process on every historical shoreline file

Step 3a: Pre-process of the shorelines and Edit the Shorelines Feature class
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Create a new shapefile Merging the historical shorelines.

Open Search tab → Merge → Merge Data Management
• In the field Input, insert the historical shorelines (Drag and Drop)
• In the field output, define the file name and the saved folder

Save as → Shoreline_2015_2021_sm
• In the Field Map, Delete the all fields e.g. DN (Long), Keep only

the field YEAR, press ΟΚ

Open attribute table to check the fields

Step 3b: Pre-process of historical shorelines



Common borders. Common solutions.Common borders. Common solutions.

• Editor → Start Editing → shorelines → OK
• Copy the shorelines from the layer Shoreline 2015-2020
• Paste to Shorelines layer

Step 3c: Edit the Shorelines Feature class
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• Select shorelines layer (right click) → Open Attribute Table
• Editor → Start Editing → shorelines

Un the fields DATE_ και UNCERTAINTY
• DATE_: the format is related to your PC settings (e.g. DAY/MONTH/YEAR or MONTH/DAY/YEAR)
• UNCERTAINTY: set the uncertainty in meters (e.g. 10 m for SENTINEL historical shorelines)

Step 3d: Edit the Shorelines Feature class
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Create a baseline parallel to the coastlines either creating a buffer line or editing manually a new polyline

Create a buffer:
• In the tab Search → type Buffer → select Buffer Analysis (Tool) and the Buffer window opens
• In the field input feature select the Shoreline_2015_2020 file
• In the Output Feature Class define the name of the buffer file and the saved file\
• In the field Distance (value or field) → select the buffer width in meters
• In the Dissolve Type → All
• Press OK
• A new buffer file is created

Step 4a: Pre-process of the baseline and import in baseline Feature Class
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• Editor → Start Editing → baseline → OK

• Create Features → select baseline
• Select the Editor from the toolbar, then select Create Features
• In the tab Create Features select baseline
• From the toolbar Editor select the tool Trace

• Set the pointer on the Buffer_shorelines → Left click → slide the pointer on the Buffer_shorelines
• Finish the sketch: left – right click and from the pop up window Finish Sketch
• Stop Editing

Step 4b: Create a baseline layer
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Step 4c: Create a baseline layer
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Step 5a: Define the technical characteristics of the vertical Transects in DSAS toolbox

Select “Set Default Parameters” button from the DSAS toolbar
Select the Baseline Settings tab
• Baseline Layer → baseline
• Baseline ID Field → ID
• In the field Location of Land relative to Baseline Orientation, 

select Left or right.

Select the Shoreline Settings tab
• Shoreline Layer → shoreline
• Shoreline Data Field → DATE_
• Shoreline Uncertainty Field → UNCERTAINTY
• In the intersection parameter select if the transects are seaward 

or landward

Press OK and the window closes 
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Step 5b: Define the technical characteristics of the vertical Transects in DSAS toolbox

Select “Cast Transects” button from the DSAS toolbar
In the tab “Cast Transects” in the fields:
• “Transect Storage Parameter” select the Geodatabase (PONTOS_PGB.mdb)
• “Select Existing or Enter New Transect Name” type a name for the new 

transects
In maximum Search Distance
• In baseline field select the transect length in meters
• In Transect spacing field select the space between new Transects
• In Smoothing Distance select the smoothing value (500)
Press OK and vertical transects to the shoreline are generated, as Shapefile
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We can edit (Delete, Add new transect or Rotate or move in space)  transects, using the  editing tools, we can:
Select the layer transects → Editor → Start editing → transects
To end the proccess select → Stop Editing

Step 6: Edit Transects 
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Select “Calculate Rates” button from the DSAS toolbar
• In the field “Select Statistics to Calculate” select the 

parameters you wish to calculate

In the field additional parameters
• Select the to apply a shoreline intersection threshold
• The confidence interval
• The output options
• And the Folder where the DSAS Summary Report is 

saved

Step 7: Calculate the Statistics from DSAS tool
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Step 8: Visualization of the DSAS results in ArcGIS

Select “DSAS Data Visualization” button from the DSAS toolbar

• In the field “Select rate to visualize using color ramp” → select the Transects_rates layer

• In the field “Select rate for color ramp display” → select the statistic parameter to visualize 
• Select “Scale to my data” or “Apply color ramp”
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Step 9: Open the Attribute tables from the generated files

• Open the Attribute tables of Transects intersect

• Open the Attribute table of Transect rates  



Common borders. Common solutions.

The parameters estimated from DSAS are:

• TRANSECT INTERSECT (data of the transect position)

• TRANSECT RATES (results of the Statistical Analysis for each transect)

Save the file as “.txt”:

Table of Contents → List by source → transects_intersects (right click) → Data → Export → Save

Step 10: Export the parameters in .txt file
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Step 11: Indicative Results – East Nestos Estuaries
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