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Module 4
The Application of Earth Observation: Wetland & Floating 
Vegetation Changes with the example of Assessments via 

PONTOS platform
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This module is developed in the framework of the BSB 889 PONTOS Project
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LEARNING OBJECTIVES OF MODULE 1

Familiarize with the QGIS software

Download and preprocess Sentinel-2 images

Understanding the Watermaks and Hydroperiod workflow

Familiriaze with the PONTOS Web Application for the Watermask and Hydroperiod generation
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MODULE STRUCTURE

Background knowledge:
    1. Introduction
    2. Images download via Copernicus access hub
    3. Add layers to QGIS and preprocessing
    4. Watermask map generation
    5. Hydroperiod map generation from series of Watermasks 

Watermask and Hydroperiod generation via PONTOS Web Application:
    1. Register and login
    2. Dataset Viewer
    3. Watermask map generation, visualization and output download
    4. Hydroperiod map generation, visualization and output download
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Background knowledge
(QGIS implementation)
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Introduction

The Watermask module generates a classified map that seperates the area in four 
different classes:
• Land
• Open water
• Emergent vegetation
• Floating vegetation

The Hydroperiod module generates a hydroperiod map from series of water masks, falling 
within the time period between the starting and the ending date of hydroperiod, by 
applying the following interpolation approach. For two dates separated by n days, the 
occurrence of water is compared. If a pixel is inundated on both dates, then it is assumed 
inundated for n-days. If a pixel is not inundated on both dates, then it is assumed 
inundated for n/2 days. The total number of days of inundation per pixel in the 
Hydroperiod map is determined by accumulating the water masks throughout the desired 
time period. 
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Steps:

1. Sentinel-2 images can be downloaded 
from the link: 
https://scihub.copernicus.eu/dhus/#
/home

2. Denoting the area of interest

3. Define the criteria for downloading 
data (Sensing Period, Cloud 
Coverage, etc.)

Sentinel-2 images download

https://scihub.copernicus.eu/dhus/#/home
https://scihub.copernicus.eu/dhus/#/home


Common borders. Common solutions.

Please contact imanakos@iti.gr / lefkats@iti.gr for more information

Add layers

Add raster layer:
Layer -> Add Layer -> Add Raster Layer

Add shape file:
Layer -> Add Layer -> Add Vector Layer
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Crop a raster to the boundaries of the shapefile (1)

Steps:
1. Layer panel -> Raster -> 

Extraction -> Clip Raster by 
Mask Layer

2. Fill the form as below:

• insert path to input layer (pick one of the “.jp2”)
• insert path of the mask layer (select the .shp file)
• check box “No data value” and set value to -1
• check “Match the extent of the clipped raster to the extent of 

the mask layer” and “keep resolution of input layer”
• insert path to Clipped (mask) to save the output
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Crop a raster to the boundaries of the shapefile (2)
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Sentinel-2 bands

Required bands for the 
Watermask and Hydroperiod 

generation
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NDVI index generation

Steps:
• Layer panel -> Raster -> Raster Calculator

• Raster Calculator Expression: 
("Clipped_B08@1"-"Clipped_B04@1" )/( "Clipped_B08@1" +"Clipped_B04@1")

• Output Layer: “NDVI”
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NDVI index

NDVI (Normalized Difference Vegetation Index): The Normalized 
Difference Vegetation Index (NDVI) measures the greenness and the 
density of the vegetation captured in a satellite image. Healthy 
vegetation has a very characteristic spectral reflectance curve which we 
can benefit from by calculating the difference between two bands – 
visible red and near-infrared. NDVI is that difference expressed as a 
number – ranging from -1 to 1.
*https://eos.com/make-an-analysis/ndvi/

https://eos.com/make-an-analysis/ndvi/
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Open Water Detection

SWIR histogram visualization

Steps: Layers -> Panel -> Right click to the 
B11 band -> Properties -> Histogram -> 
Compute Histogram

The first threshold that identifies the open 
water is detected to the first deep valley 
of the SWIR band’s histogram. In this case 
the threshold is 800.

SWIR histogram
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Open Water mask generation

Steps:
• Layer panel -> Raster -> Raster 

Calculator

• Raster Calculator Expression: 
      "Clipped_B11@1“ < 800

• Output Layer: “water_threshold”
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Emergent Vegetation Detection

The SWIR value of the pixels is 
higher in areas where water is 
covered by emergent vegetation 
compared to the SWIR values of the 
pixels having water or water with 
sparse vegetation.

The emergent vegetation is 
detected to the pixels which are 
between the first and the second 
deep valley in the SWIR histogram 
and after the first deep valley after 
the value 0.3 in the NDVI histogram.

NDVI histogramSWIR histogram
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Emergent Vegetation mask generation

Steps:
• Layer panel -> Raster -> Raster Calculator

• Raster Calculator Expression:
“Clipped_B11@1” >= 800 AND 
“Clipped_B11@1” <= 2100 AND
“NDVI@1” > 0.75
 
• Output Layer: “emergent_vegetation”
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Floating vegetation detection

The floating vegetation is detected to the pixels, which are not detected as 
open water or emergent vegetation and are meeting specific criteria, which 
are to be announced soon after the methodology is accepted and approved by 
peer reviewed online publishing process 

Note 1: The methodology is currently experimental and has not been 
announced yet

Note 2: The workflow (including floating vegetation determination) has been 
tested on the Dniester River Delta area (an Ukrainian pilot site within the 
PONTOS project). The generated results presented below have been derived 
for the Dniester River Delta area (Ukraine).
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Open water Emergent vegetation Floating vegetation 
(if existing)

Classified images
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Final Watermask map generation

The final Watermask comprising the 3 
categories (open water, emergent vegetation, 
floating vegetation). To generate the final 
Watermask, add the 3 classified images via the 
Raster Calculator.

Steps:
• Layer panel -> Raster -> Raster Calculator

• Raster Calculator Expression:
“water_threshold@1” = 1 OR 
“emergent_vegetation” = 1 OR
“floating_vegetation” = 1
 
• Output Layer: “final_watermask”
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Watermask series

01-07-2020 11-07-2020 05-08-2020

10 days 25 days
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First Hydroperiod map

For the Watermasks between 01/07/2020 and 11/07/2020 the 
difference is 10 days. If a pixel is inundated on both dates, then it 
is assumed that it is inundated for 10 days. If a pixel is inundated 
on one date, then it is assumed that it is inundated for 10/2 days. 
If a pixel is not inundated on any dates, then it is assumed that it 
is inundated for 0 days.

Steps:
• Layer panel -> Raster -> Raster Calculator

• Raster Calculator Expression:
(“2020_07_01@1” = 1 AND “2020_07_01@1” = 1)*10 +
(“2020_07_01@1” = 1 AND “2020_07_01@1” = 0)*10/2 +
(“2020_07_01@1” = 0 AND “2020_07_01@1” = 1)*10/2
 
• Output Layer: “Hydroperiod_1”



Common borders. Common solutions.

Please contact imanakos@iti.gr / lefkats@iti.gr for more information

Second Hydroperiod map

For the Watermasks between 11/07/2020 and 05/08/2020 the 
difference is 25 days. If a pixel is inundated on both dates, then it 
is assumed that it is inundated for 25 days. If a pixel is inundated 
on one date, then it is assumed that it is inundated for 25/2 days. 
If a pixel is not inundated on any dates, then it is assumed that it 
is inundated for 0 days.

Steps:
• Layer panel -> Raster -> Raster Calculator

• Raster Calculator Expression:
(“2020_07_11@1” = 1 AND “2020_08_05@1” = 1)*25 +
(“2020_07_11@1” = 1 AND “2020_08_05@1” = 0)*25/2 +
(“2020_07_11@1” = 0 AND “2020_08_05@1” = 1)*25/2
 
• Output Layer: “Hydroperiod_2”
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Final Hydroperiod map generation

The final Hydroperiod comprising the Hydroperiod_1 
and the Hydroperiod_2. To generate the final 
Hydroperiod, add the 2 generated Hydroperiods via the 
Raster Calculator.

Steps:
• Layer panel -> Raster -> Raster Calculator

• Raster Calculator Expression:
      “Hydroperiod_1” + “Hydroperiod_2@1” 

• Output Layer: “Hydroperiod”
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Final Hydroperiod map

Hydroperiod 1 Hydroperiod 2 Final Hydroperiod
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Watermask and Hydroperiod 
generation via PONTOS Web 

Application
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Create account and login

PONTOS Web Application: http://195.250.69.26:7000/

Steps:
• Navigation bar -> Log In

• Log In form -> Sign Up

• Fill the register form with username, email and 
password. Press Register.

• Fill the login form with username and password. 
Press Login.

http://195.250.69.26:7000/
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Dataset Viewer

The menu item ‘Dataset Viewer’ informs the users 
about the dates with available satellite data in 
the Web Application’s database. The Web 
Application’s database includes all available 
Level-2 data from the satellites Landsat 5, 
Landsat 8 and Sentinel-2 for the period 1984 to 
2021, which are cloud and ice free in order to 
avoid noisy outputs by the application of the 
‘Tools’. The available data are already clipped in 
the extent of the PONTOS pilots (Armenia – Sevan 
Lake and Sevan Lake Basin, Georgia – Kolkheti 
Lowlands and Black Sea coastline, Greece – Nestos 
River and River Delta, Ukraine – Dniester River 
Delta area and adjacent estuary). 
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Watermask generation (1)

Navbar -> Existing data -> Watermasks

Select pilot area
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Watermask generation (2)

Select date. The selected date 
should be included in the Dataset 
Viewer.

Click the “Submit” button to start 
the task running. The task may needs 
some hours to be completed
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Watermask Task Manager

The Task Manager contains the outputs 
of all the previous user’s submitted 
tasks.

Steps:
• Navigation bar -> Task Manager -> 

Watermaks
• Select “Details” on the submitted 

task
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Watermask task details

Task Metadata

Visualization legends

Download Watermask as GeoTIFF or 
the visualization as png
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Hydroperiod generation (1)

Navbar -> Existing data -> Hydroperiod

Select pilot area
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Hydroperiod generation (2)

Select start and end date. The 
PONTOS Web Application will 
generate the Hydroperiod for all the 
available dates (see Dataset Viewer) 
between the selected dates

Click the “Submit” button to start 
the task running. The task may needs 
some hours to be completed
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Hydroperiod Task Manager

The Task Manager contains the outputs 
of all the previous user’s submitted 
tasks.

Steps:
• Navigation bar -> Task Manager -> 

Hydroperiod
• Select “Details” on the submitted 

task
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Hydroperiod task details

Task Metadata

Visualization legends

Download Watermask as GeoTIFF or 
the visualization as png
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